i3dTHEMES safe from Heartbleed

You may have heard of the recent vulnerability in the OpenSSL system, discovered earlier this month, dubbed Heartbleed.

We wanted to reassure our users and customers that our network of servers are not (nor have ever been) affected by this vulnerability. This includes all of our web hosting servers, i3dthemes storefront and members area websites.

This is a serious vulnerability, but thankfully we run unaffected versions of the OpenSSL software. If you wish to learn more about Heartbleed, there is a website dedicated to answering your questions.